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Welcome
MLDownloader downloads intraday, end of day and historical stock quotes, Options and
Foreign Exchange (Forex) data from various Internet sites. The program gives you the
option of saving your data in MetaStock™ or in the form of ASCII files. You are
completely free to define your format of the ASCII files, so almost any Technical Analysis
software can read it. (E.g. Excel, MetaStock, OmniTrader, VISION 2000, WallStreet, etc.)
To bring your data up-to-date simply instruct MLDownloader to perform a data collection
for an individual symbol or a symbol list. With one click MLDownloader downloads,
converts and passes the data to your Technical Analysis at high speed.
You can also schedule your downloads. Specify a start time and a list of download
symbols, and MLDownloader automatically downloads the data. Optionally you can select
an external application that will be started after the download has completed. So you can
easily automate your analysis tasks.
If you have some days missed, MLDownloader automatically fills the missing days.
Example: If you have quotes till 10/07/2005 and you had not any chance to download
quotes until 21/07/2005, all missing days will be filled automatically.
MLDownloader can download quotes from over 50 international exchanges. Furthermore,
the program informs you if a component of a stock index changes. So you can be sure
that your symbol lists are always up to date!
Moreover, MLDownloader informs you when a stock is announced for split. If a stock split
is queued up MLDownloader will perform the split automatically. So you do not have to
worry about splits anymore.

Main Window
You can display the contents of a MetaStockTM directory in the main window of
MLDownloader.

(Main window of MLDownloader)

A description of the group or symbol list is displayed in the first pane of the status bar.
During the download a progress bar will be displayed in the second pane.
In the right window you can view, edit and enter the MetaStockTM price data. A datasheet
can hold up to 65,500 records (i.e., ticks, minutes, hours, days, weeks, etc.)
The data pane is similar to a spreadsheet. It is made up of individual cells in a twodimensional matrix of columns and rows. Each column displays a data field (i.e., Date,
Time, Open, High, Low, Close and Volume) and each row displays a single period's data.
The “Time” column is always “0” if you are displaying EOD data.
You can scroll the data pane up and down using the vertical scroll bar on the right side of
the data pane. You can scroll left and right in the data pane using the horizontal scroll
bar at the bottom of the data pane. To quickly move find a date/record in the view use
the Edit->Find date command.
When entering dates in the data pane, you must use the date format you have specified
in the Windows Control Panel. (Regional Settings)

Press the “F5” key or click on “Download->Update view” to update all symbol lists that
are displayed in the main window. If you want to download only a single symbol list,
select the list and click on “Download->Get Quotes”.

Portfolios/Symbol Lists
Creating/Editing a Portfolio
A portfolio is a collection of one or more symbol lists. So you can easily group your
symbol lists after certain criterions. (E.g. country)
Steps to create a new portfolio
Click on “File->New”. Now the left pane is empty.
To add a new group, click on “Portfolio->Add group”. The dialog shown below will appear.

(“Add New Group” dialog)

Type in the desired group name and click OK. Optionally you can enter a description of
the group.
Now you are able to add a symbol list file to the group. Select the group name and click
on “Portfolio->Add Symbol List”. The dialog shown below will appear.

(“Add Symbol List” dialog)

Select one or more symbol lists by using the “Browse…” button. Optionally you can enter
a description of the symbol list. If you select more than one list the description will be the
same for all symbol lists. Click on “OK” to add the symbol list to the selected group.
To save the groups/symbol lists of the portfolio, click on “File->Save”. To download the
newest data of the portfolio, click on “Download->Update view” or press the F5 key.
Note: Symbol lists of the most important stock exchanges are stored in the “C:\Program
Files\MLDownloader\Symbol Lists” directory.

Editing a Portfolio
Click on “File->Open” and select the portfolio list you want to edit. The portfolio will be
displayed in the main window. Select the group/symbol list you want to edit, and click on
“Portfolio->Edit”. (Or press the F2 key) An “Edit” dialog that is similar to the “Add” dialog
will appear. Make your changes and click on OK. To save the changes of the portfolio,
click on “File->Save”.

Creating/Editing a symbol list
A symbol list contains following information:
•
•
•

Security information: Company name, symbol and download symbol (The
download symbol can differ from the different download servers)
A directory where the downloaded data can be stored. (MetaStock and ASCII
directory)
Server from where the intraday snapshot data will be downloaded.

All securities of a symbol list will be downloaded at the same time. The data of all
securities will be stored in the same directory.
To create/edit a symbol list, click on “Symbol List->Edit”. The dialog shown below will
appear.

(“Symbol List” dialog)

Double click on a security to modify it, or click on the “Add” button to add a new security.

(“Add Security” dialog)

Enter a name, symbol and a download symbol. The “Security symbol” is used to identify
a security in a MetaStock directory. In most cases this symbol is identical to the
download symbol.

The download symbol is needed to identify the security on the server. If you do not know
the symbol name click on the “Look up” button and you will be directed to the Yahoo
security symbol look up site. You can add as many securities as you want. However the
less securities you have in a symbol list the better is the performance. It is recommended
that you do not have more than 300 securities in a symbol list.
Note: If you select the “Auto fill” option the “Security name” and “Security symbol” fields
will be filled in with the same values that you enter in the “Download symbol” field.
You can look up download symbols at:
Yahoo: http://finance.yahoo.com/l
Quote.com: http://finance.lycos.com/home/misc/symbol_search.asp
MSN: http://moneycentral.msn.com/investor/common/find.asp
Directory
You have to specify a directory where the MetaStock or ASCII files can be stored. Click
on the “Browse” button to select a directory. You can also enter a directory manually.
Note: If you enter a directory name like C:\ASCII\USA then the data will be stored there
without considering the root folder. If you enter a relative path only, like USA\Dow30,
then the data files will be stored in the sub-folders of the root folder that you have
specified in the Symbol List->Data Folders dialog.
If you are entering a relative path only, then you can change the storage location of all
symbols easily. If you are sure that you do not want to change the storage location in the
future then you can also enter an absulte path like C:\ASCII\USA.
Split in alphabetical sub directories
Select this option if you want to store all securities in a directory starting with their first
letter. The directory you enter in the MetaStock or ASCII directory text box is the root
directory.
Example:
If you have entered “C:\MetaStock” in the “MetaStock directory” text box and select this
option the security “Microsoft” will be stored in the “C:\MetaStock\M” directory. IBM will
be stored in “C:\MetaStock\I” directory and so on.
Import ASCII file
You can import any ASCII files containing security names and security symbol codes. So
you can easily add a lot of securities without manually typing it. Following dialog will
appear if you click on the “Import ASCII file” button:

(“Import ASCII File” dialog)

In this dialog you have to enter the column where the name/symbol can be found.
Furthermore, you have to specify a character that would be used as the field delimiter.
Enter “T” in the “Column separator” field if the columns are separated by a tabulator.
Finally, you have to select the ASCII file containing the name/symbols.
If the ASCII file looks like the following you have to use the settings that are shown on
the screenshot.
Microsoft, MSFT
Intel, INTC
Export to ASCII file
You can export a symbol list to an ASCII file containing only the name/symbol. Following
dialog will appear if you click on the “Export to ASCII file” button:

(“Export Symbol List to ASCII file” dialog)

First, you have to enter a name of the ASCII file. Click on the “…” button to browse for a
file. Finally, you have to enter a column separator. Enter “T” if you want to separate the
columns with a tabulator.
If you use the settings from the above screenshot an ASCII file like following will be
created:
Microsoft, MSFT
Intel, INTC

Importing MetaStockTM files
Click on the “Import MetaStock directory” button to import all securities of a MetaStockTM
directory. A dialog will be displayed where you can select the directory. All securities of
this directory will be displayed in the “Symbol List” dialog automatically.
For non US/Canadian securities it is required to add a suffix to the download symbol. You
can do this by clicking on the “Change symbol prefix/suffix” button. If you have imported
German securities, you have to add the suffix “.DE”, for French securities the suffix “.PA”
etc.
Changing symbol prefix/suffix
Click on the “Change symbol prefix/suffix” button to change the prefix/suffix of the
symbols and download symbols.

(“Change Prefix/Suffix” dialog)

The prefix/suffix will be added to all symbols that are displayed in the “Symbol List”
dialog. To remove a prefix/suffix you have to select the “Remove” checkbox.
Filter Securities
Click on the “Filter” button to display the “Define Filters” dialog.

(“Define Filters” dialog)

You can filter all securities that had no activity the last xx days. After you have clicked
“OK” all securities with no activity will be selected in the “Symbol List” dialog. Use the
“Delete” button to delete the securities from the symbol list and from the MetaStock
directory.

Keeping Symbol Lists up-to-date
MLDownloader can download the components of following indices:
BUSE Merval (Argentina)
All Ordinaries (Australia)
NZSX 40 (Australia)
ATX (Austria)
ATX Midcap (Austria)
ViDX (Austria)
BEL20 (Belgium)
Bovespa (Brazil)
S&P TSX COMP (Canada)
KFX (Denmark)
KVX (Denmark)
SX All Share PI (Denmark)
DJ Euro STOXX 50 (Europe)
DJ Stoxx AUTO P (Europe)
DJ Stoxx BANK P (Europe)
DJ Stoxx BASI P (Europe)
DJ Stoxx CHEM P (Europe)
DJ Stoxx CCYC P (Europe)
DJ Stoxx CNCY P (Europe)
DJ Stoxx CNST P (Europe)
DJ Stoxx ENGY P (Europe)
DJ Stoxx FINS P (Europe)
DJ Stoxx F&BV P (Europe)
DJ Stoxx IND P (Europe)
DJ Stoxx INSU P (Europe)
DJ Stoxx MDIA P (Europe)
DJ Stoxx HEAL P (Europe)
DJ Stoxx RETL P (Europe)
DJ Stoxx TECH P (Europe)
DJ Stoxx TCOM P (Europe)
DJ Stoxx UTIL P (Europe)
DJ E.StoxxAUTO P (Europe)
DJ E.StoxxBANK P (Europe)
DJ E.StoxxBASI P (Europe)
DJ E.StoxxCHEM P (Europe)
DJ E.StoxxCCYC P (Europe)

DJ E.StoxxCNCY P (Europe)
DJ E.StoxxCNST P (Europe)
DJ E.StoxxENGY P (Europe)
DJ E.StoxxFINS P (Europe)
DJ E.StoxxF&BV P (Europe)
DJ E.StoxxIND P (Europe)
DJ E.StoxxINSU P (Europe)
DJ E.StoxxMDIA P (Europe)
DJ E.StoxxHEAL P (Europe)
DJ E.StoxxRETL P (Europe)
DJ E.StoxxTECH P (Europe)
DJ E.StoxxTCOM P (Europe)
DJ E.StoxxUTIL P (Europe)
CAC 40 (France)
NM-FR Price (France)
SBF 120 (France)
DAX 30 (Germany)
TecDAX (Germany)
SDAX (Germany)
MDAX (Germany)
Midcap Market (Germany)
Prime All Share (Germany)
Technology All Share
(Germany)
Classic All Share (Germany)
Hang Seng (Hong Kong)
Irish SE (Ireland)
BSE Sensex (India)
S&P CNX Nifty (India)
MIB 30 (Italy)
Mibtel (Italy)
Numtel (Italy)
Midex (Italy)
MXSE IPC GRAL (Mexico)
AEX Components
(Netherlands)
AMX Components
(Netherlands)

Oslo All Share (Norway)
Oslo Obx (Norway)
PSI20 (Portugal)
Straits Time (Singapore)
BT-SRI (Singapore)
UOB Sesdaq (Singapore)
KLSE Composite
(Singapore)
Madrid General (Spain)
IBEX 35 (Spain)
SAX All Share (Sweden)
OMX (Sweden)
SMI (Switzerland)
SPI General (Switzerland)
SNMI (Switzerland)
FTSE 100 (United Kingdom)
FTSE 250 (United Kingdom)
FTSE AIM (United Kingdom)
FTSE TECHMARK (United
Kingdom)
Dow Jones 30 Industrials
(USA)
Dow Jones 20
Transportation (USA)
Dow Jones 15 Utilities
(USA)
Dow Jones 65 Composite
(USA)
Nasdaq 100 (USA)
S&P 500 (USA)
S&P 100 (USA)
S&P 400 MidCap (USA)
S&P 600 SmallCap (USA)

Clicking on the “Symbol List->Update” menu causes the following dialog to be displayed:

(“Symbol List Update” dialog)

Select the symbol lists you want to update. Also make sure that the root directory is
correct. This directory should point to the symbol lists you want to update.
Note: Do not change the names of the default symbol lists of MLDownloader. If you
change the names, the program cannot update the symbol lists.
Click on “Update lists” to check if the components of some indices have changed.
MLDownloader will automatically remove old securities and will download historical data
for new securities (optional).
Command Line
You can also start the "Symbol List Update" dialog from the command line using following
syntax:
C:\MLDownloader\MLDownloader.exe –UpdateSL
The program will be closed automatically after the symbol lists were updated
successfully.

Clicking on the “Options” button causes following dialog to be displayed:

(“Symbol List Update Options” dialog)

Manually confirm changes
Tick off this option if you want that you will be asked for each change that will be made
on the symbol list.
Store deleted securities in following directory
You can define a directory where the stocks that were removed from a symbol list are
stored.

Data Folders
By default all quotes will be stored in the folders “C:\MetaStock\Country\Index Name” or
“C:\Ascii\Country\Index Name”. It would be very troublesome and time-consuming if you
want to change the folder of all symbol lists. (e.g. “C:\Ascii\USA\Dow30” to “E:\My
Stocks\USA\Dow30”)
In the Symbol List->Data Folders you are able to specify a root folder where the data of
all symbol lists will be stored. Furthermore, you are also able to choose whether to store
the data files in sub folders of the root folder, or store the data in one directory that
contains alphabetical sub directories (A-Z).

(“Data Folders” dialog)

Example:

Supposing that you have a symbol list where the name of the MetaStock folder is
USA\Dow30. Whenever you download data and are using the “Store securities in sub
folders…” option, the data will be stored in the “C:\MetaStock\USA\Dow30” folder. If you
change the MetaStock root folder to “E:\My Stocks” and start the download again then
the data will be stored in the “E:\My Stocks\USA\Dow30” folder. If you have a symbol list
containing an full folder name like “C:\MetaStock\USA\Nasdaq100” then data will be
stored in this folder without considering the MetaStock root folder.
The program will store all the data files in sub directories (A-Z) if you tick off the “Store
securities of all symbol lists in one directory” option.
Use same data folder settings for each portfolio
Tick off this option to use the same data folder settings for all portfolios that you will
create in the future. If you do not use this option then you are able to create portfolios
containing different root folders.
Important update information for users that are using version 7.0 or lower
The symbol lists that were used in MLDownloader 7.0 or lower have all full folder names
like “C:\MetaStock\USA\Dow30”. Therefore the MetaStock root folder cannot be used. To
solve this program you have to download the new symbol lists on http://www.tradingtools.com/downloads/symbollists71.zip and replace them with the symbol lists on your
computer. Alternatively, you can also uninstall MLDownloader completely and redownload the program from http://www.trading-tools.com/downloads/mldownloader.zip

Removing duplicate Security Records
MLDownloader scans your portfolio and searches for duplicate securities. To start the
scan, click on “Portfolio->Search for duplicate Securities”. Following dialog will be
displayed after the scan:

(“Remove duplicate Security Records” dialog)

All duplicate securities and the symbol list containing the securities will be displayed.
Select the securities (press the “Ctrl” key to select more securities at the same time) you
want to remove and then click on the “Remove selected securities” button. The securities
will be removed from the symbol list and from the MetaStock directory.
If you want to delete all duplicate securities of one symbol list you only have to select
one entry of this symbol list. Afterwards you have to click on the button “Select all
entries of selected symbol list”. MLDownloader will select all the other entries of this
symbol list automatically.

Download
Options Dialog
Download Options
To open the “Download Options” dialog, click on the “Download->Options” menu entry.

(“Download Options” dialog)

MetaStock file format
Select this option to store the data in MetaStock format. MLDownloader supports the old
MetaStock format (255 symbols per directory) as well as the new MetaStock format.
(6000 symbols per directory) Moreover, you can create MetaStock data files containing
only 5 data fields. (Date, High, Low, Close, Volume) Some old chart programs can only
read MetaStock files having 5 data fields. To make changes on the Metastock format,
click on the “Change” button. The “MetaStock Format Options” dialog will appear:

(“MetaStock Format Options” dialog)

ASCII file format
Select this option to store the data in the form of ASCII files. You are able to define the
format of the ASCII files. (Click on “Define custom ASCII file formats” button) Take a
look at the “Defining a custom ASCII file format” chapter for more information.
Server
You have to define a server that can be used for downloading missing days. If a server is
down, you can easily switch between the servers that are supported by MLDownloader.
Create a download history log file
All download attempts will be recorded if you select this option. A HTML file will be
created containing download date, time, parameters used, date ranges and errors
occurred during the download.
To create a report file for each download attempt use the “<TIME>” tag. (E.g.
“C:\MLDownloader Reports\<TIME>_Report.html”). MLDownloader replaces the
“<TIME>” tag with the time when the download was started.
To create a report file for each day use the “<DATE>” tag. (E.g. “C:\MLDownloader
Reports\<DATE>_Report.html”). MLDownloader will create a new report file for each day.
To create a report file for each week use the “<WEEK>” tag. (E.g. “C:\MLDownloader
Reports\<WEEK>_Report.html”). MLDownloader replaces the “<WEEK>” tag with the
day when you start a download the first time. A new report file will be created
automatically every seven days.
A report file can be viewed by any Internet Browser and looks like following picture:

Download last xx days again
MLDownloader will automatically download the last xx days again and checks if the data
that is stored on your computer is the same as the data from the server. If the data is
different MLDownloader automatically replaces the old values with the newest data from
the server.
Divide volume quotation by …
Select this option to divide the volume quotation of each security by 10, 100, 1000,
10000 or 100000.

Internet Connection Settings Dialog

(“Internet Connection Settings” dialog)

Time-out interval
You can select a time-out value (in seconds) to receive a response to a request. If the
response takes longer than this time-out value, the request is canceled.
Number of retries
You can set the number of attemts how often the program should try to send a request
to the server. Set this value to 6-8 retries if you have a very slow Internet connection.
Number of simultaneous downloads
You can specify the number of securities that can be downloaded at the same time. This
value is only used for historical download.
Initial delay
Set a value (in milliseconds) if the program should wait before it send a download
attempt to the server.
Dial-up connection
A dial-up connection will be created every time when a download starts. The connection
will be closed automatically when all securities have been downloaded.
Proxy Server
If your Internet service provider requires you to define a proxy server, then define the
Proxy settings according to your network configuration. Enter the server name and the
port number. Port “8080” is the right value in most cases. For further details please
contact your network administrator.

Preferences Dialog

(“Preferences” dialog)

Expand group items
The root nodes of the left main window will be expanded automatically when
MLDownloader will be started.
Check for splits/dividends when program starts
MLDownloader informs you when a stock is announced for split or a dividend was
distributed. If a stock split is queued up or a dividend was distributed, MLDownloader will
automatically recalculate the whole stock’s history. So you do not have to worry about
dividends and splits anymore.
Start download again in XX seconds
The “Download Error” dialog displays all securities whose last download was
unsuccessful. MLDownloader will automatically download the securities again whose last
download failed. You can also manually download the securities again, by clicking on the
“Download securities again” button in the “Download Error” dialog.
Inspect for invalid symbols when the “Download Error” dialog was displayed
MLDownloader will automatically check those securities where the download failed. If the
symbol of a security has changed the program will update the symbol list with the new
symbol automatically.

Display “Download finished successfully” dialog
A “Download finished successfully” message box will appear every time when a download
completed successfully.
Store securities with different intervals in one directory
A MetaStock directory can contain data of a security with the same name when the time
interval is different. E.g. Daily EOD data and 5 minute intraday data etc.
Open security in SmartChart or MetaStock
If you double click on a security in the main window the security will be opened in
SmartChart or MetaStock automatically.
Display warning when the price is XX percent higher/lower than the previous
price
A warning message will be displayed in the “Download Errors Report” when the last price
that was downloaded is XX percent higher/lower than the previous price.
Do not display warning messages in the “Download Errors Report” dialog
Only error messages will be displayed in the “Download Errors Report” dialog. All warning
messages will not be displayed.

URL Properties Dialog

(“URL Properties” dialog)

As you may have noticed from browsing the Internet many financial websites display
information about a particular stock based on its symbol. Now suppose that you see that
a company BigCharts has the following URL for Microsoft(MSFT) stock:
http://bigcharts.marketwatch.com/quickchart/quickchart.asp?symb=msft
You may type in the URL part preceding the stock symbol
http://bigcharts.marketwatch.com/quickchart/quickchart.asp?symb= in the Chart, First
URL part in the dialog above. Click OK button and the default URL for displaying the
charts will be changed to BigCharts. Sometimes there is URL continuing after the symbol,
you may extract it and type in the second URL part.
To set URLs to defaults click the “Use default URLs” button.

Defining a custom ASCII file format
To open the “Download Options” dialog, click on “Download->Options”. Then you have to
click on the “Define custom ASCII file formats” button to display the “ASCII File Format”
dialog.

(„ASCII File Format“ dialog)

Supported fields and column assignments
You use the check boxes to declare which fields you want MLDownloader to create in
your ASCII file. For each checked item you must declare in which column that data field
is found. MLDownloader does not permit multiple assignments to the same column. The
“Date” field and the “Close” field are not optional - the ASCII file must have a “Date”
column and a Close column. You can also specify the number of digits that are displayed
after the comma.
Check the “Use a custom comma sign” box to use a different comma sign as you have
specified in the Control Panel (Regional country settings). If you do not check this box
the default comma sign will be used.
Check the “Enclose labels in quotation marks” box if you want that a quotation mark is
set before and after the date, time, name and symbol.

Example:"ATML","02/22/02",7.550001,7.18,7.400001

Input File: Detail Settings
You should choose which character would be used as the field delimiter. That character
pertains to all columns and data in the file.
You can select the Date field format in your ASCII source. There are different formats
supported. Example 1: YYYY-MM-DD means that the year is expressed as a four-digit
number and that the three fields are separated by a “-“ character. Example 2: MMDDYY
means that the year, month and day are expressed as a two digit numbers each no
characters separate the fields.
Check the “Remove zeros at the begin of the date” box to remove all leading zeros of the
date. Example: The date 000101 (1. January 2000) will be written to the ASCII file as
101.
Start/End line of the ASCII file
Enter a string that will be written at the begin/end to every ASCII file. Use the “\L” string
to make a line break.
Example: Line1\LLine2 will be stored in the ASCII file as:
Line1
Line2
Ascii file name
You cannot enter a static name for the ASCII file. The ASCII file names will be created
dynamically. You can select wheter the ASCII file name contains the symbol name and/or
the download symbol (a separate ASCII file for each security will be created) or the
current date and/or the symbol list name (a ASCII file for all securities of a symbol list
will be created).
Examples
• Separate ASCII file for each security:
You have to tick off the “Symbol” and/or “Name” check boxes.
The name of the ASCII file can look like this: MSFT_Microsoft.txt
The contents of the file can look like this:
2004/09/17,27.39,27.53,27.26,27.51,65283000
2004/09/20,27.44,27.65,27.33,27.51,51513600
2004/09/21,27.45,27.53,27.25,27.26,73874400
•

Separate ASCII file for each day:
You have to tick off the “Date” and/or “Symbol list name” check boxes.
The name of the ASCII file can look like this: Dow Jones 30
Industrials_20040923.txt
The contents of the file can look like this:
2004/09/21,^DJI,10204.52,10291.39,10159.54,10244.93,13250000
2004/09/21,MMM,81.27,81.80,80.40,81.57,3028100
2004/09/21,AA,31.03,31.40,30.90,31.27,5134200

If you want to store data of a security with different intervals in one directory you have
to check the option “Add interval/peridocity to the file name”. The interval code will be
automatically added at the end of the file name. The ASCII files can look like this:
• MSFT_Microsoft_D.txt (Daily format)
• MSFT_Microsoft_15.txt (15 Minute interval)
• MSFT_Microsoft_30.txt (30 Minute interval)
At least you have to enter a file extension. E.g. txt, csv etc.

ASCII Fille Format Templates
You can use an ASCII file format template. Click on the “Load Template” button to
display the “ASCII Format Templates” window. The names of the most common
charting/technical analysis software packages are displayed in the dialog. Select a
template and click on the “OK” button. Now MLDownloader will store the ASCII files in
the format that can be read by the program you have just selected in this dialog.

(“ASCII Format Templates” dialog)

Get Quotes Dialog
To download end of day (EOD) or historical data click on “Download->Get Quotes”. The
dialog shown below will appear.

(“Get Quotes” dialog)

Downloading latest data (EOD data)
If you want to make a download using a symbol list select the “Use a portfolio or symbol
list files” option. Click on the “Browse” button and select one or more symbol lists you
want to download. The MetaStock or ASCII files will be stored in the directory that is
defined in the symbol list file. By default MLDownoader stores the data in the
subdirectories of “C:\MetaStock” resp. “C:\Ascii”. Please take a look at the chapter
“Creating/Editing a symbol list” if you want to know how to change the directory where
the data is stored.
Note: You can enter more than one symbol lists in the “Symbol list(s)” field. So you are
able to download several symbol lists at the same time.
You can also download quotes using only one download symbol. Check the “Use a single
download symbol” option and enter a download symbol select a server and specify a
directory where the data can be stored. If you do not know the name of a download
symbol click on the “Look up” button to get a list of download symbols. Enter the
download symbols in the form “Symbol1+Symbol2+Symbol3” (e.g. MSFT+NET+AXP) if
you want to download multiple securities at the same time. (This feature can only be
used to download EOD data, not historical data)
Select the option “Download latest data” and click on the “Download latest data” button
to start the download.

Downloading historical EOD data
To download historical quotes select the “Download historical data” option and enter a
start/end date.
You can use the Yahoo and the MSN.com server to download historical quotes for free.
The “Quote.com” server is not free.
Select the “Download adjusted Close prices” to download close prices that are adjusted
for dividends and splits.
Downloading historical intraday quotes
Historical intraday quotes are only provided by the “Quote.com” server. If you download
historical intraday quotes the start and end date is ignored. You will get a maximum of
500 quotes. This is a server limitation. Historical intraday quotes are only available for
US and Canadian markets.
To use the “Quote.com” server you have to sign up for a “Open LiveCharts™ Basic”
subscription at http://www.quote.com for $ 9.95/month if you want to use this server.
This subscription allows you to download historical intraday data, historical EOD data and
Futures data.
Note: The free demo account of “Quote.com” will not work.
After you have singned up you will receive a user name and password. You have to enter
the user name and password in the “Get Quotes” dialog. Quote.com can only use your
coded password. Following steps are necessary to find out your coded password:
Log in on Wuote.com and go to following URL:
http://finance.lycos.com/home/livecharts/default.asp?symbols=NASDAQ%3AMSFT&
origsymbols=msft
Now click on the Chart button. Select the menu “Export Chart -> Bardata to Ascii Text”.
A new browser window with the following URL will be opened:

Your coded password is the string after the “&Pswd=” tag. In that case the password is
“01MWurYJUEzA”.
Note: If you want to download historical quotes for European securities you have to use
the US download symbols for these securities. You can look up US download symbols at:
http://finance.yahoo.com/l. You also have to use the “Yahoo” server. MSN, Quote.com
and Wallstreetcity provide only data for US and Canadian securities. Historical intraday
quotes can only be downloaded for the US and Canadian securities.
Filling missing days (e.g. 21th June 2005 until today)
If you have some days missed, MLDownloader automatically fills the missing days. It is
not necessary to define a start and end date. MLDownloader checks the last date and fills
the missing days if required. (Do not check the “Download historical quotes” check box!)
Filling gaps (e.g. 2nd June 2005 until 14th June 2005)
Let us assume that you have a gap between the date 02/06/2005 and 14/06/2005. The
last record of the data file is 18/06/2005.
To fill the gap you have to select the “Download historical data” option. Use 02/06/2005
as start and 14/06/2005 as end date. Click on “Download historical data”. MLDownloader
downloads the missing days and stores the price records in the right sequence.

Download new securities only
If this option is selected MLDownloader only downloads securities that do not exist in the
data directory but exist in the symbol list file. This option is useful if you have added one
or more securities to a symbol list and want to download the data of the new securities
only.
Example:
You have a data directory containing following securities: MSFT, DJI and IBM. A new
security was added to the symbol list. Now the symbol list contains the symbols MSFT,
DJI, IBM and INTC. The history of MSFT, DJI and IBM is already stored in the data
directory. Therefore there is no need to download the data of these securities again. If
you perform a download of the symbol list and select the “Download new securities only”
option then data for INTC will be downloaded only.
Note: This feature only work for MetaStock files.
Adjusted Close Price
Data is adjusted using appropriate split and dividend multipliers, adhering to Center for
Research in Security Prices (CRSP) standards. Split multipliers are determined by the
split ratio. For instance, in a 2 for 1 split, the pre-split data is multiplied by 0.5. Dividend
multipliers are calculated based on dividend as a percentage of price, primarily to avoid
negative historical pricing. For example, when a $0.08 cash dividend is distributed on Feb
19 (ex-date), and the Feb 18 closing price was 24.96, the pre-dividend data is multiplied
by (1-0.08/24.96) = 0.9968. Below is a detailed example of adjusted close calculations.
Example: Adjusted Close Calculations
2/13/03
2/14/03
2/18/03
2/18/03
2/19/03
2/19/03

Close = 46.99
Close = 48.30
Split = 2:1
Close = 24.96
Cash Dividend = 0.08 (ex-date)
Close = 24.53

Split Multiplier = 0.5
Dividend Multiplier = 1 – (0.08/24.96) = 0.9968
2/13/03
2/14/03
2/18/03
2/19/03

Adj.
Adj.
Adj.
Adj.

Close
Close
Close
Close

=
=
=
=

0.5 * 0.9968 * 46.99 = 23.419816
0.5 * 0.9968 * 48.30 = 24.07272
0.9968 * 24.96 = 24.880128
24.53

If a dividend or split has occurred, MLDownloader downloads the whole entire stock's
history again considering the splits/dividends. (Currently this works for US stocks only)
Please make sure that you tick of the “Check for splits/dividend when program starts and
recalculate entire stock’s history” option in the “Download->Options->Preferences”
dialog.

Displaying erroneous data/Retrying download attempts
After the download of one or more securities failed, the “Download Errors” dialog will be
displayed.

(“Download Errors” dialog)

You can see all securities where the last download attempt failed. The download symbol,
the error description and the directory where the securities should be stored are
displayed.
Download again
Click on “Securities->Download again” if you want to retry downloading the securities.
Only the securities that are displayed in the dialog will be downloaded again.
Example: If two securities of a symbol list with 30 symbols failed to download, only the
two securities will be downloaded again. (Not the complete symbol list!)
Remove from symbol list
To remove the selected securities from the symbol list, click on “Securities->Remove
from symbol list”.
Inspect invalid symbols
If you get an error message “No data available (Invalid symbol or wrong start end date
specified)” you should use the “Inspect invalid symbols” function. If you call this function
(Securities->Inspect invalid symbols) MLDownloader will connect to the Yahoo server and
checks if the symbol code on the server was changed. As a result you will get the new
symbol code. MLDownloader updated the symbol list with the new symbol code
automatically.
Copy Errors to Clipboard
To copy the errors that are displayed in the “Download Errors” dialog to the clipboard,
click on “Securities->Copy Errors to Clipboard”. Then you can open any text editor and
paste the error messages there.

Scheduling/Autodownload
The scheduling feature allows you to start MLDownloader at a specific time. You only
have to define the symbol lists you want to use and the quotes will be downloaded
automatically.
Click on ”Download->Timer” to define the download start times.

(“Scheduling” dialog)

Click on “Add task” to add a new task. The dialog shown below will appear.

(“Trigger” dialog)

Start time
Select a time when MLDownloader should be started to download quotes.
After download has finished
You can select if MLDownloader should shut down the computer, start an external
application (MLDownloader will be closed after the application has been started) or close
MLDownloader.
Symbol list
Select one or more symbol lists to download.
Download historical quotes
Select the server you want to download from. If you use the “Quote.com” server, make
sure that you have entered a valid user name and password in the “Download->Get
Quotes” dialog.
Also enter the number of days that the program should download. The end date is always
the date when the download occurs. MLDownloader automatically calculates the start
date. (E.g. Let us assume that today is the 31/08/2003. If you select “Download last 2
days”, MLDownloader will download quotes for, 29/08/2003, 30/08/2003 and
31/08/2003)

Sorting Price Data Dialog
The “Tools->Sort” dialog is used to sort the price data for the selected security(s). The
price data is sorted chronologically.

Note: This feature only works for MetaStockTM files.

(“Sorting Price Data” dialog)

Sort
Use the Sort command to sort the price data in the selected securities chronologically.
Browse
Choose the Browse button to display the “Select Folder” dialog. Use the “Select Folder”
dialog to change the data folder displayed in the “Sorting Price Data” dialog.
Duplicate records
Select the “Delete duplicated records” check box to remove all duplicate records.

Splits/Dividends
Show Announced/Past Splits/Dividends Dialog
Use the “Tools->Show Announced/Past Splits and Dividends” dialog to receive a list of
announced splits and dividends that will be paid. Click on the “Past Splits” tab to get a
list of the past splits. Please make sure that you are connected to the Internet.
MLDownloader always downloads the latest information from the Trading-Tools.com
server. The announced split list shows all stocks that are announced for splits regardless
whether you have already performed the split on your computer or not. At the moment
this feature works for US stocks only.

(“Announced Splits” dialog)

Select a security and click on the “Perform split” button to perform a split.

Split
The Split function is used to adjust the price data and volume for a stock split. Please use
caution when applying this command. Once an adjustment is made, it may be difficult to
bring the data back to its original state.

(“Split” dialog)

Enter a directory where the security you want to split is located. Also enter the symbol
and the ratio. Use the “Search” button if you do not know, where to security is located.
More information
When a stock splits, the historical prices must be adjusted to reflect the split. For
example, if XYZ company has a 2 for 1 stock split, shareholders will receive two shares
for each share that they own. To keep the total market value of the stock equal, the price
per share is reduced by one-half. Therefore shareholders will have twice as many shares
at half the price. Stock splits are usually done in order to increase the liquidity of the
stock.
When price data is adjusted for a stock split, the volume is also affected. For example, in
a 2 for 1 split where prices are cut in half, the volume is doubled so that the market
value remains unchanged.
Example
Price records before using Split function (Open, High, Low, Close, Volume):
33.1800 33.2800 32.1300 32.9500 1351801
Using the split function:
Ratio: 2:1
Price records after using the Split function (Open, High, Low, Close, Volume):
16.5900 16.6400 16.0650 16.4750 2703602

Automatic Stock Splits and Dividends Adjustments
If you select the “Check for splits/dividends when program starts and recalculate entire
stock’s history” option in the “Download->Options->Preferences” dialog, MLDownloader
checks for stock splits and dividends automatically each day. (Once per day when you
start MLDownloader the first time) If a stock split is queued up or a dividend was paid,
MLDownloader will automatically recalculate the whole stock’s history. It is important
that the stock that is announced for split/dividend must exist in your portfolio; else the
program will not be able to perform this operation automatically. At the moment this
feature works for US stocks only.
A dialog will appear where you have to confirm whether to recalculate the entire history
or not. The dialog will close automatically after 15 seconds and the program will start to
recalculate the entire history.

(“Recalcualte Entire History” dialog)

Tutorial
Downloading quotes using a symbol list
Open the “Get Quotes” dialog. (“Download->Get Quotes”)
Select the option “Use a portfolio or symbol lists files”. Click on the “Browse” button and
select the symbol list “Dow Jones 30 Industrials.mld”. By default this file is located in the
“C:\Program Files\MLDownloader\Symbol List\USA” directory.
Click on “Download current quotes”. During the download you will see a status window.
By default the data of the symbol list “Dow Jones 30 Industrials.mld” will be stored in the
“C:\MetaStock\USA\ Dow Jones 30 Industrials” directory. You can change the directory in
the “Symbol List” dialog. After the download has finished you will be able to open the
directory “C:\MetaStock\USA\Dow Jones 30 Industrials” with any program that can read
MetaStockTM files.
Storing quotes in ASCII files
MLDownloader also offers the possibility to store quotes in ASCII format. To enable this
option you have to open the “Download Option” dialog (“Download->Options”) and select
the option “A custom defined ASCII file format”. If you want to change the ASCII file
format click on “Define custom file formats”. Close the dialog and repeat the steps above.
By default the quotes of the symbol list “Dow Jones 30 Industrials.mld” are stored in
following directory: “C:\ASCII\USA\ Dow Jones 30 Industrials”.

Manually filling gaps
Let us assume that you have a MetaStockTM database containing valid data from 20th
August 2000 until 30th June 2001 and from 16th July 2001 until today. As you have
already noticed there is a gap from 1st July to 15th July. Following steps are necessary to
fill this gap:
• Open the “Get Quotes” dialog. (“Download->Get Quotes”)
• Select the symbol list containing the gap
• Select the option “Download historical data”
• Enter a start date (1st July 2001) and end date (15th July 2001)

•

Click on “Download historical quotes”

MLDownloader downloads the missing days and automatically stores the price records in
the right sequence.

Automatically filling missing days
Let us assume that you have a MetaStockTM database containing valid data from 20th
August 2000 until 14th October 2002. As you have already noticed there is a gap from
14th October 2002 until today. Following steps are necessary to fill this gap:
• Open the “Get Quotes” dialog. (“Download->Get Quotes”)
• Select the symbol list containing the gap
• Select the option “Download latest data”
• Click on “Download latest data”

Automatically Correct Open, High and Low Prices
During the stock exchanges are opened, the Open, High and Low price is zero. (The
Yahoo server only provides the Close price) A warning is displayed in the “Download
Report” dialog if the prices are zero.

(“Download Report” dialog)

You can use the timer feature of MLDownloader to download the securities where the
OHL price is zero again. You only have to specify the time when the stock exchanges will
close and MLDownloader will do the rest for you.
Click on “Securities->Timer” menu. Following dialog will appear:

(“Select Securities” dialog)

Tick off the option “Warnings” and click on the “OK” button. Following dialog will appear:

(“Trigger Info” dialog)

Enter a time in the “Start time” field when MLDownloader should start downloading the
data.
The “Task name” and “Portfolio/Symbol list” fields are disabled. The symbol lists that are
displayed in the “Portfolio/Symbol list” field containing all symbols that have no OHL
price.
MLDownloader will start automatically at the time you have specified and fills in the
Open, High and Low prices automatically.

FAQ (Frequently asked questions)
Which trading software is compatible with MLDownloader?
MLDownloader can store quotes in MetaStockTM format or in form of ASCII files.
Therefore any software that is able to read ASCII files is compatible to MLDownloader.
Just a few of them: AmiBroker, Advanced GET, Elliot Wave, Hermes, Homebroker, Excel,
MetaStock, OmniTrader, VISION 2000, Wall$treet, etc.
Which data does MLDownloader support?
MLDownloader allows you to download stock quotes, indices, mutual funds, corporate
bonds, warrant, FOREX data, etc.
How long is the data history?
That depends upon the symbol how far the historical data hoes back. You can check it
out at http://finance.yahoo.com. The history for FOREX data goes back to January 1999.

Are stock quotes displayed in real-time?
No, they are 15-20 minutes delayed quotes. If you want to have real-time quotes take a
look at http://www.trading-tools.com/real-time-quotes-downloader.htm. There you will
find a tool providing real-time quotes.
How does MLDownloader handle split and dividends?
Data is adjusted using appropriate split and dividend multipliers, adhering to Center for
Research in Security Prices (CRSP) standards. Split multipliers are determined by the
split ratio. For instance, in a 2 for 1 split, the pre-split data is multiplied by 0.5. Dividend
multipliers are calculated based on dividend as a percentage of price, primarily to avoid
negative historical pricing. For example, when a $0.08 cash dividend is distributed on Feb
19 (ex-date), and the Feb 18 closing price was 24.96, the pre-dividend data is multiplied
by (1-0.08/24.96) = 0.9968. Below is a detailed example of adjusted close calculations.
Example: Adjusted Close Calculations
2/13/03
2/14/03
2/18/03
2/18/03
2/19/03
2/19/03

Close = 46.99
Close = 48.30
Split = 2:1
Close = 24.96
Cash Dividend = 0.08 (ex-date)
Close = 24.53

Split Multiplier = 0.5
Dividend Multiplier = 1 – (0.08/24.96) = 0.9968
2/13/03
2/14/03
2/18/03
2/19/03

Adj.
Adj.
Adj.
Adj.

Close
Close
Close
Close

=
=
=
=

0.5 * 0.9968 * 46.99 = 23.419816
0.5 * 0.9968 * 48.30 = 24.07272
0.9968 * 24.96 = 24.880128
24.53

If a dividend or split has occurred, MLDownloader downloads the whole entire stock's
history again considering the splits/dividends. (Currently this works for US stocks only)
Please make sure that you tick of the “Check for splits/dividend when program starts and
recalculate entire stock’s history” option in the “Download->Options->Preferences”
dialog. Alternatively, you can also manually search for splits/dividends by clicking on the
“Tools->Search Securities where Dividends/Splits occurred” menu item.
Why is the adjusted close price downloaded by MLDownloader different from
the Yahoo adjusted close price?
On the Yahoo server the adjusted close price is available with 2 decimals only. After a
few adjustments, it is not sufficiently accurate. Therefore MLDownloader does not use the
adjusted close price from Yahoo. Consequently, MLDownloader has its own function to
calculate the adjusted close price. The formula for the calculation is exactly the same as
Yahoo is using. However, MLDownloader does not round the result to 2 decimals only
which leads to lack precision.
Furthermore, MLDownloader adjusts the volume also for dividends.
Example:
Assume a company distributed a $0.20 dividend in 2004 and its volume were 250,000 on
the ex-date. Later in 2005, the company split the stock 2:1. Consequently, the raw data
downloaded from Yahoo would now show a $0.10 dividend in 2004 and 500,000 shares
traded on the dividend ex-date in 2004. MLDownloader further adjusts OHLC/V based on
this information.

Can I download option data?
Yes. If you use the Yahoo server you can only download end-of-day data, no historical
data. Use the Quote.com server to download historical data.
Use following information to find out more information about option symbols:
http://biz.yahoo.com/opt
http://www.quote.com
How can I download historical FOREX data?
Historical FOREX data are available back to January 1999. A symbol list with all
supported currency pairs can be found in the “C:\MLDownloader\Symbol Lists\Forex.mld”
directory. To download the data click on "Download->Get Quotes”. Then select the
“Forex.mld” list using the "Browse" button. Then select the option “Download historical
data” and select the "Forex data" server. Click on the “Download historical data” button
to start the download.
Why does the “Quote.com” server not work?
You have to sign up for a “Open LiveCharts™ Basic” subscription at
http://www.quote.com for $ 9.95/month. This subscription allows you to download
historical intraday data, historical EOD data and Futures data. A subscription for the
quote.com server is only needed if you want to download historical intraday quotes.
Historical EOD data can be downloaded from the Yahoo server for free.
Note: The free demo account of “Quote.com” will not work.
After you have signed up you will receive a user name and password. You have to enter
these values in the “Download dialog”. Quote.com can only use your coded password.
Following steps are necessary to find out your coded password:
Log in on quote.com and goto following URL:
http://finance.lycos.com/home/livecharts/default.asp?symbols=NASDAQ%3AMSFT&
origsymbols=msft
Now click on the Chart button. Select the menu Export Chart -> Bardata to Ascii Text. A
new browser window with the following URL will be opened:

Your coded password is the string after the “&Pswd=” tag. In that case the password is
01MWurYJUEzA.
I have existing historically data (Metastock format) and want to update this
with MLDownloader. Is this possible?
Yes that is possible. Click on the Symbol list->Wizard menu. Then select the option
“Create symbol lists using existing MetaStock directories”. Click on “Next” and follow the
instructions in the “Symbol List Wizard” dialog.
How can I store data of a security with different interval in one directory?
Click on “Options” in the “Download” menu. In the “Options” dialog you have to click on
the “Define custom ASCII file format” button. Now you have to check the option “Add
interval/peridocity to the file name”. The interval code will be automatically added at the
end of the file name. The ASCII files can look like this:
• MSFT_Microsoft_D.txt (Daily format)
• MSFT_Microsoft_15.txt (15 Minute interval)
• MSFT_Microsoft_30.txt (30 Minute interval)
At the end of the download the error message “Access denied” occurs.
This error occurs when MLDownloader tries to add new securities to a directory and this
directory is currently opened by MetaStock. (or any other program) You have to close the
program before new securities can be added to the directory.

When I want to open a security within Metastock, I get the error "Not a Valid
Metastock for Windows file"
You have to change the "Files of Type" to "Smart Charts". So the Open dialog will display
the list of your securities.
What is the data source of MLDownloader?
At the moment MLDownloader uses following servers:
http://www.yahoo.com
http://www.quote.com
http://www.msn.com
How does MLD cope with different symbols from different services?
The indices symbols will be automatically converted from e.g. “^DJI” (Yahoo) to “$DJI”
(MSN.com). Most of the other symbols are identical.
How can I update my symbol lists?
You can use the update feature of MLDownloader. (Symbol Lists->Update) Please go to
the “Keeping Symbol Lists up-to-date” chapter in the help file to find out more details.
Moreover, you can use the “Inspect invalid symbols” function to check if a symbol code
has changed. Fore more details please take a look at the “Displaying erroneous
data/Retrying download attempts” chapter.
I have added new securities to my symbol list. How can I download the
historical data of the new securities only?
Click on “Download->Get Quotes”. Make sure that the option “Download new securities
only” is selected. Then MLDownloader will only download the securities that have been
added to the symbol list.
How can I add a large list of stocks without manually typing them?
There are two ways:
1. Click on "Symbol List->Edit". Afterwards click on the "Import ASCII file" button. Then
select an ASCII file that contains all the securities you want to import. Specify a column
separator and the columns where the name and symbol information is stored. Then click
on import.
2. There is an Excel file named “Convert2MLD.xls” located in the directory where you
have installed MLDownloader. (By default this directory is “C:\Program
Files\MLDownloader”) This Excel workbook allows you to convert stock lists to the
MLDownloader symbol list format. You only have to enter all the download symbols in
column “A” and the stocks names in column “B”. Click on “Convert” and you have a
symbol list that can be used by MLDownloader.
How can I download a symbol list using the command line?
First you have to define the lists you want to download. Click on "Download->Timer".
Enter a task name and select the lists you want to download. Click on OK.
Now you can run MLDownloader using following command line:
C:\Program Files\MLDownloader\MLDownloader.exe -MLD_<TASKNAME>
C:\Program Files\MLDownloader\MLDownloader.exe -MLD_test
You have to replace the "test" with your task name.
To open the "Symbol List Update" dialog from the command line enter following
command:
C:\Program Files\MLDownloader\MLDownloader.exe -UpdateSL

How can I remove invalid stock symbols from my symbol lists without deleting
them manually?
After the download has finished the "Download Report" dialog will appear. All symbols
that are invalid will be displayed in this dialog. All you have to do is to click on
"Securities->Remove from Symbol List". Then MLDownloader will remove all invalid
symbols from the symbol lists automatically.

(“Download Report” dialog)

How can I remove duplicate securities in my portfolio?
Click on the Portfolio->Search for duplicate Securities menu entry. MLDownloader will
display a list with all duplicate securities. Click on the “Remove selected securities”
button to remove all duplicate securities.
However, e.g. Microsoft belongs to both Nasdaq 100 and the Dow Jones 30 list. If you
delete this symbol one group looks not completed. Therefore it is also possible to store
all securities of a portfolio in one directory. Each portfolio has subdirectories of A, B,
C,...Z, 0,1,..9 and each symbol's data will be downloaded to those subdirectories based
on its start letter or number. Like MSFT will be placed only in the M subdirectory.
On the other hand, you can have different groups for displaying data like Nasdaq100,
S&P 500, etc. When clicking each symbol within a group, it will actually load data from
the subdirectory which saves its data.
To enable this function you have to click on the “Portfolio->Settings” menu entry. Tick
the option “Store securities of all symbol lists in one directory”. In the MS and Ascii
directory text boxes you have to enter the directories where the data files should be
stored.
Where can I enter the unlock key?
Start MLDownloader and click on Help->Register. A dialog appears where you can enter
the unlock key.

Registration and Price Information
This copy of MLDownloader is available for a 14 days evaluation period. If you decide to
continue using the program, you need to register the program by using one of the
methods described below. By registering the software, you are able to continue using it
legally, and are supporting our efforts to continually develop innovative products to best
serve your needs. If you order via credit card you receive the fully registered version of
MLDownloader within 5 minutes.
With a single license you can run the program on two computers that are owned by you.
If you want to run the program on more computers then you have to buy additional
licenses:
Product price (one time payment, free updates)
Single license: 59.95 Euro (can be used on two computers)
2-5 licenses: 54.95 Euro per license
6-14 licenses: 49.95 Euro per license
15 or more licenses: 35.95 Euro per license
If you decide to buy MLDownloader and SmartChart you get both programs for only
99.95 Euro instead of 119.90 Euro
All discounted software can be ordered online. For each license package we will email you
one special license key that you can use to unlock the specified number of installations of
the software.
Click on the link below to make your order on a secure web site. You can pay via credit
card, wire transfer, cash or check.
http://shareit1.element5.com/product.html?productid=157007
Alternatively you can order via phone, fax or postal mail. Please print out the order form.

We also accept orders via PayPal!
After you have placed your order, you will receive an unlock key within 24 hours. Go to
http://www.paypal.com and log in into your account. Click on "Send Money". Enter
"info@trading-tools.com" in the "Recipient's Email" text box. Also enter your name and
the name of the program you want to order in the "subject" text box. Click on continue
to complete the order.
Benefits
•
•
•
•

of Registering:
No restrictions on the number of starts
No download limitation
Free updates
Free technical support provided by email. Questions usually answered within
24 hours.

Upgrade
If you are a registered user of MLDownloader you may upgrade at no charge to any
newer release. Just download the latest release of MLDownloader and install it.
If the registration code is no longer present on your system just re-enter it like the first
time and restart the program.
If for any reason your registration code becomes invalid or lost just send an e-mail to
mailto:info@trading-tools.com together with the details of your previous registration. You
will receive a new code via e-mail at no charge.

Order form
Please print out the following form and fax or mail it to:
element 5 AG / ShareIt!
Vogelsanger Strasse 78
50677 Koeln
Germany
Phone: +49-221-2407279
Fax: +49-221-2407278
Email: register@shareit.com
US customers may also order by calling 1-800-903-4152 (9am-5pm). No technical
support can be given at this number. US check and cash orders can be sent to our US
office at
ShareIt! Inc.
PO Box 844
Greensburg, PA 15601-0844
USA

Order form for MLDownloader
Program No.: 143484
Last name: ___________________________________
First name: ____________________________________
Company: ____________________________________
Street and #: ______________________________________
City, State, postal code: ________________________________
Country: _______________________________________
Phone: _____________________________________
Fax: ________________________________________
E-Mail: ______________________________________

How would like to receive the registration key?
E-mail - fax

- postal mail

How would you like to pay the product price of € (EURO) 59.95?
Credit card - wire transfer - Euro Cheque - cash

Credit card information (if applicable)
Credit card: Visa - Eurocard/Mastercard - American Express - Diners Club

Cardholder: ________________________________
Card No.: ___________________________________
Date of Expiration: ___________________________________

Date / Signature ___________________________

Contact
We provide support via email. You can email your questions, comments or bug reports to
info@trading-tools.com. Normally all emails are answered throughout the 24-hour day.
Please take a look at the FAQ (http://www.trading-tools.com/faq.htm). Perhaps your
question is already answered there.
If you have a question that could be interested for anyone feel free to post in our forum!
http://forum.trading-tools.com. If you need a fast answer it is better to contact us via
email.
Keep the following tips in mind:
Always make sure that you are using the latest version.
Software Problems: It is easier to solve a software problem if you send us details that
are as specific as possible when inquiring about software problems. Also tell us the
operating system you are using.
Data Problems: Again, details that are as specific as possible is necessary in order to
resolve any data problems quickly. Please specify the stock name and the date in
question when reporting a data problem. Specifying what you think is wrong is also
useful.
Web: http://www.trading-tools.com
Forum: http://forum.trading-tools.com

Disclaimer of Warranty
Please note that by using MLDownloader you are accepting the conditions of the Software
License and Disclaimer of Warranty given below.
IMPORTANT - READ CAREFULLY
MLDownloader is shareware program. This means:
1. All copyrights are exclusively owned by Trading-Tools.com.
2. Once registered, the user is granted a nonexclusive license to use MLDownloader on
one computer (i.e. a single CPU), for any legal purpose, at a time. The registered
MLDownloader software may not be rented or leased.
3. To register you must fill out the registration form. For more information please refer to
the "Help" files. To purchase, go to http://www.trading-tools.com/order.htm.
4. MLDownloader is distributed "AS IS". No warranty of any kind is expressed or implied.
You use it at your own risk. You assume responsibility for selecting the software to
achieve your intended results, and for the installation of, use of, and results obtained
from the software. The author will not be liable for data loss, damages, loss of profits or
any other kind of loss while using or misusing this software and/or any kind of data
derived.
5. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile,
disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset
of the licensed program, except as provided for in this agreement. Any such
unauthorized use shall result in immediate and automatic termination of this license and
may result in criminal and/or civil prosecution.
6. You are not allowed to sell your unlock key to other persons using eBay or similar
platforms.
7. Trading-Tools.com reserves the right to change the price for the program or any
service without prior notice. Trading-Tools.com does not refund the purchases of
shareware programs which have trial period.
8. If at any time in the future Yahoo!Finance or any other quotes source used in
MLDownloader stops to provide the data, Trading-Tools.com will not be liable for the
program stops to work. In such case Trading-Tools.com will not refund your purchase
neither.
9. MLDownloader relies on free data providers of financial data. Trading-Tools.com
cannot be held responsible for the accuracy of the data provide, however we are
committed to adding new sources of free data in the future.
10. If you do not agree with the terms of this license you must remove MLDownloader
files from your storage devices and cease to use the product.
MetaStockTM is a registered trademark of EQUIS International. (http://www.equis.com)
Thank you for choosing MLDownloader!

